Compile and install a new version of Python and/or Apache http server.