* Y2038 compliance
* Pluggable Keywords
* configure_requires in CPAN module meta data (META.yml)
* deprecations warn by default